login language problem

Linux болон нээлттэй эхийн програм хангамжтай холбоотой асуудлууд, ерөнхий ойлголт.

Зохицуулагч: Bathuyag

Post Reply
tab

login language problem

Бичлэг Бичсэн tab » 2009-03-16, 11:49

Англи хэл дээр хэрэглээтэй хүмүүсд /ubuntu 8.10 дээр/ хэлний бэрхшээл гардаггүй бололтой юм. Миний хувьд эхлүүлэх гээд login нэр нэвтрэх үгээ хийх гэхээр монголоор бичигдээд болдоггүй ээ. Энэ талаар харсан үзсэн туршилгаа хуваалцана уу. Орос хэл дээр оросуудад иймэрхүү бэрхшээл шийдвэрлэсэн гэж байна. Үүийг ойлгодоггүй. Үүнд:
1, Компьютерээ асаа "esc" дар
2, Ингээд "e" товчлуур товш.
3, Доош гүйлгэх сумаар <kernel> сонго. Дахин "e" товчлуур товш.
4, ro quiet splash оронд rw init=/bin/ bash
5. enter дараад "b" товших
6, Ингээд нэр асууна гээд байх юм. Нэрээ англиар бичиж болно гэж байх юм.
7, reboot хийнэ.
Үүнийг туршаад болдоггүй.
Энэ талаар дэлгэрэнгүй тайлбар хийж өгнө үү. 23_11_52[1].gif 23_11_52[1].gif 23_11_52[1].gif 23_11_52[1].gif 23_11_52[1].gif 23_11_56[1].gif 23_11_56[1].gif 23_11_56[1].gif 23_11_56[1].gif 23_11_56[1].gif 23_11_56[1].gif 23_11_52[1].gif 23_11_52[1].gif 23_11_52[1].gif 23_11_52[1].gif 23_11_52[1].gif :eek:

Хөрөг
Almas
☆★☆卍 ★ 卍☆★☆
☆★☆卍 ★ 卍☆★☆
Бичлэг: 2636
Элссэн: 2005-02-12, 22:25
Танилцуулга: Монголчууд маань компьютер гэдэг юмыг гартаа оруулж бүгд өөр өөрийн ажил, амьдралдаа мессенжер, тоглоом тоглох, бичиг баримт шивихээс илүүгээр ашиглаад сурчихвал улс орны маань хөгжил тэр чигээр нь чирснээс илүү дугуйтай тэргэн дээр тавиад түрсэн мэт урагшаа өнхрөх байх гэж боддог юм. Анх 2005 оноос Дусал.нэт веб сайтыг Форум хэлбэрээр ажиллуулж эхлэсэн. Олон олон найзуудтай болсон, хамтарч бас нэлээд юм сурч мэдсэн, гэж боддог. Цаашдаа ч гэсэн...
Байрлал: Дэлхий дээр л ;-)
Contact:

Бичлэг Бичсэн Almas » 2009-03-18, 12:15

Монгол хэлийг үндсэн хэлээр тавиад ер нь дэмий шүү дээ. Бас system wide тохиргоон дээр тавих бүүр ч дэмий.
Нэвтрэх цонхон дээрээ Ctrl+Alt, Alt+Alt, Alt+Shift товчны хослолуудаар нэг Англи хэл солих гээд оролдоод үз дээ. Та өөрөө товчны хослол сонгосон бол тэр хослолоор тань солигдох ёстой байх... Хэрвээ болохгүй бол дээрх аргаар засах хэрэгтэй болно. Нэлээн төвөгтэй...

Дээр заасан арга бол зөвхөн рүүт эрхээр нэвтрэхийг зааж байна. Ингэж орчихоод xkb тохиргоогоо Англи руу болгож янзлах хэрэгтэй.

Ингэхдээ дээрх аргаараа нэвтэрч ороод тушаалын мөрөнд ажиллах хэрэгтэй. Ингэхдээ бас vi editor ашиглаж чаддаг байх хэрэгтэй.

Код: Бүгдийг сонгох

$ sudo vi /etc/X11/xorg.conf
нээгээд гарны тохиргооны хэсгийг доорх байдлаар өөрчилж өгөөд хадгалж гараад тооцоолуураа дахин ачааллах хэрэгтэй.

Код: Бүгдийг сонгох

    Section "InputDevice"
        Identifier "Keyboard1"
        Driver "Keyboard"

        Option "XkbModel" "pc104"
        Option "XkbLayout" "us"
        Option "XKbOptions" ""
    EndSection
Live CD ашиглаж ороод мөн иймэрхүү байдлаар суусан байгаа үбүнтүгийнхээ xorg.conf файлыг засаж болно.

Хэрвээ vi ашиглаж чадахгүй, бүүр хэцүү байвал шууд устгаад үз.

Код: Бүгдийг сонгох

$ sudo rm /etc/X11/xorg.conf
Харь гаригийнхан байдаг :D

Post Reply

Буцах